Evgeny Karkan Evgeny Karkan - 4 months ago 82
Ruby Question

Travis CI, unable to run tests - Error: activesupport requires Ruby version >= 2.2.2

I have an open sourced

Obj-C
repository with
Kiwi
unit testing framework as
CocoaPods
dependency.

To run tests I'm using
Travis CI
continious integration tool.

Everything was fine previously, all unit tests were executed, but now I'm getting Travis CI build error:

ERROR: Error installing cocoapods:
activesupport requires Ruby version >= 2.2.2.


enter image description here

Here is my
.travis.yml
file:

language: objective-c

before_install:
- sw_vers
- cd EKAlgorithmsApp

install: make install

script: make ci


And here is my
Makefile
:

install:
gem install cocoapods --no-ri --no-rdoc
gem install xcpretty --no-ri --no-rdoc
pod install

ci:
xcodebuild -workspace EKAlgorithmsApp.xcworkspace/ -scheme EKAlgorithmsSpecs -sdk macosx -configuration Release clean test | xcpretty -c


It seems that something in configurations has changed on Travis CI side, but I'm not very familiar with Ruby, so I need a help of how to fix that warning to run my tests successfully.

Answer

Solved it by adding next line to my .travis.yml file:

osx_image: xcode7.3

So my .yml file now looks like:

language: objective-c
osx_image: xcode7.3

before_install:
- sw_vers
- cd EKAlgorithmsApp

install: make install

script: make ci