Afolabi Olaoluwa Akinwumi Afolabi Olaoluwa Akinwumi - 3 months ago 189x
JSON Question

Could not find json-1.8.3 in any of the sources Run `bundle install` to install missing gems

I am using a Windows 8 for development. My problem started when I tried to install Ruby 2.2.2 using the Rails Installer, which was even epileptic to the source code am trying to clone.

I uninstalled RailsInstaller for Ruby2.2.2 and my old Ruby2.0.0 Development console started giving me problems/errors.

Here is the Error when I run bundle install:

Gem files will remain installed in F:/Rails
Template/vendor/bundle/gems/json-1.8.3 for inspection. Results logged
to F:/Rails Programs/RubymineProjects/Rails-Bootstrap
An error occurred while installing json (1.8.3), and Bundler cannot
continue. Make sure that `gem install json -v '1.8.3'` succeeds before

I also tried to install JSON as instructed, but also failed:

ERROR: Could not find a valid gem 'json' (>= 0), here is why:
Unable to download data from - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B:
certificate verify failed ( atest_specs.4.8.gz)

I have tried virtually everything I found relating to this but all to no avail.

A few things I tampered with are DevKit, which I set to Ruby 2.2.2 but I reconfigured it to Ruby 2.0.0 after uninstalling Ruby 2.2.2.


Here are the steps I have taken to solve the problem.

  1. I removed all json entries from Gemfile.lock, then
  2. I did run bundle install, then
  3. rails server

and it worked. Thanks.