mahdi pishguy mahdi pishguy - 2 months ago 45
Node.js Question

Nodejs install adonis-framework get error

when i try to create simple project as adonis new awesome-project i get error:

adonis new awesome-project

Cloning into 'awesome-project'...
cleaning project
setting up app key
Fixing ace file
installing dependencies may take a while
installing dependencies... |
> spawn-sync@1.0.15 postinstall /home/mahdi/Desktop/Home/www/adonisjs/awesome-project/node_modules/spawn-sync
> node postinstall

installing dependencies... | ERR! Linux 3.19.0-32-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v4.5.0
npm ERR! npm v2.15.9
npm ERR! code EBADPLATFORM

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: fsevents@1.0.14
npm ERR! notsup Valid OS: darwin
npm ERR! notsup Valid Arch: any
npm ERR! notsup Actual OS: linux
npm ERR! notsup Actual Arch: x64
installing dependencies... /
npm ERR! Please include the following file with any support request:
npm ERR! /home/mahdi/Desktop/Home/www/adonisjs/awesome-project/npm-debug.log
undefined
mahdi@HP-EliteBook:/var/www/adonisjs$


My linux operating system is
ubuntu
and i'm familiar
nodejs
, i don't have any problem for work with that

Answer

From the adonis documentation: Node.js version 4.0 or greater. npm version 3.0 or greater.

You have to upgrade your npm version to 3.8.9 in order to solve the problem. (npm install -g npm@3.8.9)

With any version higher there seems to be issue the same issue.

Related links: https://github.com/adonisjs/adonis-framework/issues/161 / https://github.com/npm/npm/issues/12647

Comments