Dr Confuse Dr Confuse - 17 days ago 9
Python Question

Unable to install rodeo or spyder in my Ubuntu?

I'm trying to install an IDE for native ML/DA work but both of the top IDEs (spyder and rodeo) dont install on my system.
syder installed using

python3.5 -m pip install spyder

but when I try to run spyder from Terminal using
spyder
I get the following error:

Traceback (most recent call last):
File "/usr/local/lib/python3.5/dist-packages/qtpy/__init__.py", line 119, in <module>
from PySide import __version__ as PYSIDE_VERSION # analysis:ignore
ImportError: No module named 'PySide'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/local/bin/spyder", line 11, in <module>
sys.exit(main())
File "/usr/local/lib/python3.5/dist-packages/spyder/app/start.py", line 103, in main
from spyder.app import mainwindow
File "/usr/local/lib/python3.5/dist-packages/spyder/app/mainwindow.py", line 49, in <module>
requirements.check_qt()
File "/usr/local/lib/python3.5/dist-packages/spyder/requirements.py", line 39, in check_qt
import qtpy
File "/usr/local/lib/python3.5/dist-packages/qtpy/__init__.py", line 125, in <module>
raise PythonQtError('No Qt bindings could be found')
qtpy.PythonQtError: No Qt bindings could be found


When I try to install
PySide
, I get:

only these python versions are supported: [(2, 6), (2, 7), (3, 2), (3, 3), (3, 4)]


I currently use python3.5 for analysis and python2.7 for webdev.

So I uninstalled spyder using
python3.5 -m pip uninstall spyder
and try to install rodeo using pip as well as apt-get and neither work. I even tried
sudo dpkg -i install rodeo.deb
as explained here and got the following error:

dpkg: error processing archive install (--install):
cannot access archive: No such file or directory
dpkg: error processing archive rodeo.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
install
rodeo.deb


Trying to download rodeo from their website at yhat.com loads a blank page with a single line
Cannot GET /products/rodeo/downloads/linux64/null
and nothing happens - no download.

How do I install & use either one of these IDEs or something that would generally make ML/DA work easier?

And I haven't played with alternate builds of python such as anaconda, jupyter, ipython, etc.

Thanks

Answer

Based on https://pythonhosted.org/spyder/installation.html#the-hard-way, the "No Qt bindings could be found" error for Spyder can be fixed by installing either PyQt5, which is recommended, or PyQt4 for Python 3. In Ubuntu, you can install PyQt5 by running:

sudo apt-get install python3-pyqt5

If you want to install PyQt4 instead, then run:

sudo apt-get install python3-pyqt4