张文枫 张文枫 - 4 months ago 20
Android Question

Can "v17 leanback library"(android tv support library) support 2.x or 4.x device?

I have some trouble when develop on TV device, Can "v17 leanback library" support 2.x or 4.x device?

"v17 leanback library" is a TV Support Libraries.It request the app's minSdkVersion is "android-L",so app can't run on 2.x or 4.x device.Do you have some suggest?

you can visit enter link description here for more infomation.

Answer

This seems to be quite an old question and since the Lollipop announcement, I guess it's easy to say that yes, since the Leanback API has been integrated in a support library.

compile 'com.android.support:leanback-v17:21.0.0'

I actually had some fun implementing the samples and my custom apps using it on Android KitKat and it all works like a charm.

Interesting to say though, you won't have the nice transitions as you can see them on Lollipop.

Edit: It is important to know that the leanback library supports all API levels starting from 17. However, you won't have all transitions and the BackgroundManager will not work prior to API 21.

Comments