tkowt tkowt - 3 years ago 249
PHP Question

phpunit 5.6.4 doesn't work in php 5.6 for doctrine's dependency via composer

I have a problem composer install dependencies.
We use php which is version 5.6.24.
When installing phpunit 5.6.4, we install doctrine needs php^7. This is our partial composer.lock after require and install phpunit.

"packages-dev": [
"name": "doctrine/instantiator",
"version": "1.1.0",
"source": {
"type": "git",
"url": "",
"reference": "185b8868aa9bf7159f5f953ed5afb2d7fcdc3bda"
"dist": {
"type": "zip",
"url": "",
"reference": "185b8868aa9bf7159f5f953ed5afb2d7fcdc3bda",
"shasum": ""
"require": {
"php": "^7.1"

Why does it cause and How do we fix this dependency from php 7 to 5?
As I thought, It is possible of using phpunit 5.6.4 in php 5 as show. (We use cakephp 2.10.3 depending on sebastian/exporter 1.2. So we can use only under 5.6.4 phpunit version.)

and we use docker ,so we install library following command .

docker run --rm -it -v $(pwd):/app composer:1.4.1 require --dev phpunit/phpunit:"5.6.4" --ignore-platform-reqs --update-with-dependencies

Answer Source

This problem is caused by incompatible of doctrine version (see and phpdocumentor/reflection-docblock and as it show. I can override invalid versions to use command composer

require (or --dev) package:$correct_version

Of course , as well as docker environment.

Composer file can have ambiguous dependencies' match setting like ^、〜 operator, therefore dependencies will be broken if library installed to be required by dependencies change requirements which has updated incompatible before. So we need implicitly definitions of their correct version in composer.json. Thanks to @TonyChiboucas's comment add your own requirement definition. It becomes a clue to resolve my problem.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download