Usman Khan Usman Khan - 21 days ago 9
Ruby Question

Getting error 'Bundler could not find compatible versions for gem "railties"'

I am following Michael Hartl's ruby on rails tutorial and while deploying my first app, I am getting the following error:

Bundler could not find compatible versions for gem "railties":

In Gemfile:

rails (= 4.0.0) x86-mingw32 depends on
railties (= 4.0.0) x86-mingw32

sass-rails (= 4.0.0) x86-mingw32 depends on
railties (4.0.1.rc3)


My Gemfile looks like the following:

source 'https://rubygems.org'

ruby '1.9.3'

gem 'rails', '4.0.0'

group :development do
gem 'sqlite3', '1.3.8'
end

gem 'sass-rails', '4.0.0'

gem 'uglifier', '2.1.1'

gem 'coffee-rails', '4.0.1'

gem 'jquery-rails', '3.0.4'

gem 'turbolinks'

gem 'jbuilder', '~> 1.2'

group :doc do
# bundle exec rake doc:rails generates the API under doc/api.

gem 'sdoc', require: false

end


Any idea what I'm missing here?

Answer

I would reinstall the railties gem again then

gem install railties