cartant cartant - 1 month ago 9
Node.js Question

How to determine which Node APIs are supported by which version

When introducing new modules to a project - as a maintainer - how can you determine which built-in APIs are supported by a particular Node.js version? Or the Node.js version in which they were introduced?

For example, the

API was introduced in
v0.12
, but there is no mention of this in the function-level documentation.

Answer

Version information is slowly being added to the documentation for various modules. However at the time of this writing, the util module does not have this information yet. PRs are welcome of course :-)