DevanDevak DevanDevak - 2 months ago 153
R Question

R installation errors on ubuntu 14.04

I am trying to install R on my ubuntu 14.04 and i am incurring lot of errors in this aspect

when i run r-base-core i am getting following errors , please let me know what changes i have to do to install these broken packages

dev@dev-OptiPlex-780:~$ sudo apt-get install r-base-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
r-base-core : Depends: libc6 (>= 2.23) but 2.19-0ubuntu6.9 is to be installed
Depends: libgomp1 (>= 4.9) but 4.8.4-2ubuntu1~14.04.3 is to be installed
Recommends: r-recommended but it is not going to be installed
Recommends: r-base-dev but it is not going to be installed
Recommends: r-doc-html but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I have checked the installation version of Libc6 and this is what i obtained

libc6:
Installed: 2.19-0ubuntu6.9
Candidate: 2.19-0ubuntu6.9
Version table:
*** 2.19-0ubuntu6.9 0
500 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
100 /var/lib/dpkg/status
2.19-0ubuntu6 0
500 http://de.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libc6-dev:
Installed: 2.19-0ubuntu6.9
Candidate: 2.19-0ubuntu6.9


and even libgomp1

Installed: 4.8.4-2ubuntu1~14.04.3
Candidate: 4.8.4-2ubuntu1~14.04.3
Version table:
*** 4.8.4-2ubuntu1~14.04.3 0
500 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
100 /var/lib/dpkg/status
4.8.2-19ubuntu1 0
500 http://de.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages


Also r-base-core cache

root@dev-OptiPlex-780:/home/dev# apt-cache policy r-base-core
r-base-core:
Installed: (none)
Candidate: 3.3.1-1xenial0
Version table:
3.3.1-1xenial0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ xenial/ Packages
3.3.1-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
500 http://ppa.launchpad.net/marutter/rrutter/ubuntu/ trusty/main amd64 Packages
3.3.0-2xenial0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ xenial/ Packages
3.3.0-2trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.3.0-1xenial0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ xenial/ Packages
3.3.0-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.5-1xenial 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ xenial/ Packages
3.2.5-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.4-revised-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.4-1trusty 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.3-6trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.3-4trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.3-3trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.3-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.2-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.1-4trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.1-3trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.1-2trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.1-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.0-4trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.2.0-1trusty 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.1.3-1trusty 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.1.2-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.1.1-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.1.0-1trusty0 0
500 http://cran.rstudio.com/bin/linux/ubuntu/ trusty/ Packages
3.0.2-1ubuntu1 0
500 http://de.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

Answer

As I suspected in my comment above, you have 'confused' your system by pointing to Ubuntu 16.04 aka xenial as shown in your output:

root@dev-OptiPlex-780:/home/dev# apt-cache policy r-base-core
r-base-core:
  Installed: (none)
  Candidate: 3.3.1-1xenial0
  Version table:
     3.3.1-1xenial0 0
        500 http://cran.rstudio.com/bin/linux/ubuntu/ xenial/ Packages

The fix is simple. In /etc/apt/sources.list or one of the /etc/apt/sources.list.d/*.list replace xenial with trusty and run apt-get update. After that you should be able to update.

Comments