marreBUS marreBUS - 1 month ago 8
Apache Configuration Question

Apache won't run even though port 80 is available

So I used Apache last time yesterday, opening up Port 80 so that it could access it. Today, without changing any settings, it won't start. I've made Port 80 available, I've tried changing the Listen 80 to Listen 8080 and multiple other ports but it won't work. I've also opened XAMPP in administrator since I've read that it could be privilege problems, but that doesn't seem to be the problem aswell. The error message I receive is:

17:16:51 [Apache] Attempting to start Apache app...

17:16:51 [Apache] Status change detected: running

17:16:51 [Apache] Status change detected: stopped

17:16:51 [Apache] Error: Apache shutdown unexpectedly.

17:16:51 [Apache] This may be due to a blocked port, missing dependencies,

17:16:51 [Apache] improper privileges, a crash, or a shutdown by another method.

17:16:51 [Apache] Press the Logs button to view error logs and check

17:16:51 [Apache] the Windows Event Viewer for more clues

17:16:51 [Apache] If you need more help, copy and post this

17:16:51 [Apache] entire log window on the forums

EDIT: Apache doesn't seem to update the error_log file aswell. So I can't find any information there. I guess this is the problem, but I've found nothing to solve it.

Leo Leo
Answer

i assume Apache Service is installed and running

press Windows+R and run services.msc

Find service name Apache and stop it.

In xampp Control panel you will find service with green sign or red x sign

Uninstall Apache service then install it and then try to start Apache on port 80

this should work, else try reinstalling xampp.