TienLe TienLe - 4 months ago 6x
iOS Question

Project using UIAlertController. How to building IPA file with Xcode 5.1?

My project is using UIAlertController. It's work fine and i can build an IPA file on Xcode 6.1.

But when i'm trying build an IPA file on Xcode 5.1. It is not work because Xcode 5.1 cant find interface declaration for 'UIAlertController'. Any ideas?

P/S: sorry about my english.


It's not possible. UIAlertController was introduced in iOS 8 and only Xcode 6+ supports iOS 8+.

As Apple's docs on UIAlertController show the class is "Available in iOS 8.0 and later." Source below: https://developer.apple.com/Library/ios/documentation/UIKit/Reference/UIAlertController_class/index.html