Stepan Yudin Stepan Yudin - 2 months ago 19
PHP Question

Cannot install DoctrineMigrationsBundle via composer

Project uses Symfony 2.8.2, PHP version is 5.6

I'm trying to install DoctrineMigrationsBundle and composer fails with error:

Problem 1
- doctrine/doctrine-migrations-bundle 1.0.0 requires doctrine/migrations ~1.0@dev -> satisfiable by doctrine/migrations[v1.0.0, v1.1.0, v1.2.0, v1.2.1, v1.2.2, v1.3.0].
- doctrine/doctrine-migrations-bundle 1.0.1 requires doctrine/migrations ~1.0@dev -> satisfiable by doctrine/migrations[v1.0.0, v1.1.0, v1.2.0, v1.2.1, v1.2.2, v1.3.0].
- doctrine/doctrine-migrations-bundle 1.1.1 requires doctrine/migrations ~1.0 -> satisfiable by doctrine/migrations[v1.0.0, v1.1.0, v1.2.0, v1.2.1, v1.2.2, v1.3.0].
- doctrine/doctrine-migrations-bundle v1.1.0 requires doctrine/migrations ~1.0 -> satisfiable by doctrine/migrations[v1.0.0, v1.1.0, v1.2.0, v1.2.1, v1.2.2, v1.3.0].
- doctrine/migrations v1.3.0 requires php ^5.5|^7.0 -> your PHP version (5.5.28) or "config.platform.php" value does not satisfy that requirement.
- doctrine/migrations v1.2.2 requires php >=5.4.0 -> your PHP version (5.5.28) or "config.platform.php" value does not satisfy that requirement.
- doctrine/migrations v1.2.1 requires php >=5.4.0 -> your PHP version (5.5.28) or "config.platform.php" value does not satisfy that requirement.
- doctrine/migrations v1.2.0 requires php >=5.4.0 -> your PHP version (5.5.28) or "config.platform.php" value does not satisfy that requirement.
- doctrine/migrations v1.1.0 requires php >=5.4.0 -> your PHP version (5.5.28) or "config.platform.php" value does not satisfy that requirement.
- doctrine/migrations v1.0.0 requires php >=5.4.0 -> your PHP version (5.5.28) or "config.platform.php" value does not satisfy that requirement.
- Installation request for doctrine/doctrine-migrations-bundle ^1.0 -> satisfiable by doctrine/doctrine-migrations-bundle[1.0.0, 1.0.1, 1.1.1, v1.1.0].


My composer.json 'require' block:

"require": {
"php": ">=5.3.9",
"symfony/symfony": "2.8.*",
"doctrine/orm": "^2.4.8",
"doctrine/doctrine-bundle": "~1.4",
"symfony/swiftmailer-bundle": "~2.3",
"symfony/monolog-bundle": "~2.4",
"sensio/distribution-bundle": "~5.0",
"sensio/framework-extra-bundle": "^3.0.2",
"incenteev/composer-parameter-handler": "~2.0",
"sensio/generator-bundle": "~2.3",
"friendsofsymfony/user-bundle": "~2.0@dev",
"sonata-project/admin-bundle": "2.3.*",
"sonata-project/doctrine-orm-admin-bundle": "2.3.*",
"stof/doctrine-extensions-bundle": "^1.2"
},


Whats wrong with my config? I tried to rollback to sf2.3 but still the same errors on bundle install

Answer

In your composer.json you should have the following :

"config": {
    "platform": {
        "php": "5.3.9"
    },
    "bin-dir": "bin"
},

Just change it to :

"config": {
    "bin-dir": "bin"
},

And it should work.