Tamil Arasan Tamil Arasan - 3 months ago 14
Android Question

Cannot Build APK

I am trying to build APK. But i am facing the error. But i can run this directly using USB debugging.

Error:12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"warning: Ignoring InnerClasses attribute for an anonymous inner class","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"(com.starmicronics.starioextension.commandbuilder.c) that doesn\u0027t come with an","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"associated EnclosingMethod attribute. This class was probably produced by a","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"compiler that did not target the modern .class file format. The recommended","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"solution is to recompile the class from source, using an up-to-date compiler","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"and without specifying any \"-target\" type options. The consequence of ignoring","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"this warning is that reflective operations on this class will incorrectly","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"indicate that it is *not* an inner class.","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"warning: Ignoring InnerClasses attribute for an anonymous inner class","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"(com.starmicronics.starioextension.commandbuilder.d) that doesn\u0027t come with an","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"associated EnclosingMethod attribute. This class was probably produced by a","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"compiler that did not target the modern .class file format. The recommended","sources":[{}]}
12:16:10.220 [ERROR] [org.gradle.api.Project] AGPBI: {"kind":"error","text":"solution is to recompile the class from source, using an up-to-date compiler","sources":[{}]}

12:16:10.235 [ERROR] [org.gradle.BuildExceptionReporter]
12:16:10.235 [ERROR] [org.gradle.BuildExceptionReporter] FAILURE: Build failed with an exception.

Answer

Add this to your build.gradle:

dexOptions {
     javaMaxHeapSize "4g"
    }
Comments