Henk Henk - 2 months ago 5
R Question

R devtools not available for R 3.0.1?

After installing Rtools30, the installation of devtools fails on a Windows 7 32 bit system:

install.packages("C:/Users/hharmsen/Downloads/devtools_1.2.zip", repos = NULL)
Warning in install.packages :
package ‘C:/Users/hharmsen/Downloads/devtools_1.2.zip’ is not available (for R version 3.0.1)

When installing directly, devtools seems to install correctly, but upon loading there is an error:

WARNING: Rtools 3.0 found on the path at c:/Rtools is not compatible with R 3.0.1.

Please download and install the appropriate version of Rtools from http://cran.r-project.org/bin/windows/Rtools/, remove the incompatible version from your PATH, then run find_rtools().

However installing devtools on R 3.0.gave no problems on a Debian 64 bit system.
Also Rtools should be compatible [R >2.15.1 to R 3.0.x].
Anyone know how to solve this?


You gave an absolute path and file to install.packages(), maybe the file is not at that location?

As explained the relevant webpage your first try should probably be


as this is a CRAN package.