BonanzaOne BonanzaOne - 3 days ago 6
Java Question

How to upgrade Artemis on WildFly

We are using WildFly 10.1.0.Final which ships with Artemis 1.1.0.wildfly-017, and we want to upgrade it to the latest maintenance version 1.1.0.SP18-redhat-1 (also considering 1.4.0 as well).

How can I upgrade Artemis without having to manually build WildFly?

Answer

I am also interested to know, as artemis-hawtio plugin is no more compatible with Artemis 1.1:

https://github.com/rh-messaging/artemis-hawtio/issues/17

I still haven't tried, but one solution could be to to replace/upgrade all the Artemis libs in:

${WILDFLY_HOME}/modules/system/layers/base/org/apache/activemq/artemis/main/lib

Do not forget to update "module.xml" accordingly.

Comments