Philipp Thölke Philipp Thölke - 9 days ago 5
Dart Question

Is it possible to develop iOS apps with Flutter on a Linux virtual machine?

I am new to developing mobile apps and wanted to try Flutter but I use Windows. Because Flutter doesn't support Windows yet I had the idea to use a virtual machine running Linux to install Flutter. Does this work?

Also in the Flutter setup it says this:


To develop Flutter apps for iOS, you need a Mac with Xcode 7.2 or newer.


Is there a way to develop iOS apps without having a Mac?

Answer

As you point in your question:

To develop Flutter apps for iOS, you need a Mac with Xcode 7.2 or newer.

You can work around by using an external service (like Travis-ci or other) to build your code for iOS. However it's not usable as a developer workflow as that can take several minutes to get the artefact.