Subash Subash - 3 years ago 146
C++ Question

How to install external library in Xcode 4?

I am thinking of completing the free online course provided by Stanford on C++ and data abstractions. They have provided a C++ library with the necessary functionality required for the course.

I am trying to install the library which is called CS106LibrariesForXcode.pkg. I have done exactly what they have mentioned in the handout. You can find the handout here.

I am using X-Code 4.3.1. Nothing happens even after I install the CS106LibrariesForXcode.pkg. Is it because of the version of Xcode I am using? How do I get it work?

Answer Source

You need to install XCode 3.0 in order to use CS106LibrariesForXcode.pkg library.

XCode 4 have a very different UI and functionality compared to XCode 3. So it would be unwise to study XCode 3 only. But if you're going to study C++ using those tutorials you'd probably want to install XCode 3 and use it.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download