Nangialai Khan Nangialai Khan - 26 days ago 7
jQuery Question

Resolving dependencies using npm while installing bootstrap 4 beta

I'm new to bootstrap 4. While installing bootstrap 4 beta (The last release of bootstrap) using npm it shows me these errors:
npm WARN bootstrap@4.0.0-beta requires a peer of jquery@>=3.0.0 but none was installed.
npm WARN bootstrap@4.0.0-beta requires a peer of popper.js@^1.11.0 but none was installed.
I'm using Git Bash, I also tried to install jquery individually but it couldn't installed
could you please help me to fix these issues?

Answer Source

You'll need to install those dependencies and save them to you package.json

npm install jquery@3.0.0 --save npm install popper.js@1.11.0 --save

The docs for npm install