tjm1706 tjm1706 - 1 month ago 16
Android Question

Osmbonuspack - osmdroid - mapsforge - library dependency issues

For android I use mapsforge tiles via osmdroid and osmbonuspack.
Till now I used the following software



Question1: Is it still requested to use the Salida solution? Or is the newer osmdroid-mapsforge library 5.x sufficient?

Question2: I am trying to get the 5.9 version working, but I cannot succceed in doing that.
What are the dependencies I have to use in Grade?

repositories {
maven { url "https://jitpack.io" };
mavenCentral();
}

dependencies {
...
compile 'org.osmdroid:osmdroid-mapsforge:5.2';
compile 'com.github.MKergall:osmbonuspack:5.9';
compile 'org.osmdroid:osmdroid-android-5.4.1-release.aar';
}


When I use this, I keep on getting errors that the osmdroid-android-5.4.1-release.aar on jcenter.bintray.com is missing.

spy spy
Answer

Question1: Is it still requested to use the Salida solution? Or is the newer osmdroid-mapsforge library 5.x sufficient?

The salida solution looks a lot like what what osmbonuspack did originally that was eventually updated and migrated into the osmdroid-mapsforge library.

Question2: I am trying to get the 5.9 version working, but I cannot succceed in doing that. What are the dependencies I have to use in Grade?

Looks like you're mixing up dependency versions

try this

dependencies { ... compile 'org.osmdroid:osmdroid-mapsforge:5.5:release@aar'; compile 'com.github.MKergall:osmbonuspack:5.9'; compile 'org.osmdroid:osmdroid-android:5.5:release@aar'; }

Comments