Marcus Leon Marcus Leon - 3 months ago 16x
Swift Question

Cocoapods: Determine pod version

How can you tell a) which version of a Pod you're using and b) how to change it?

I'm getting some compile errors with SwiftyJSON and am wondering if it's because I'm using a newer version than I'm expecting.


source ''
platform :ios, '8.0'

target ‘XXX’ do
pod 'SwiftyJSON', :git => ''


Check your Podfile.lock file. As documentation says :

This file is generated after the first run of pod install, and tracks the version of each Pod that was installed.

To change version for example to 2.2 of installed pod use :

pod 'SwiftyJSON', '2.2.0'

and run

pod install

Hope it help you