q1w2e3 q1w2e3 - 4 months ago 135
React JSX Question

Not compatible with your operating system or architecture: fsevents@1.0.11

I'm using ubuntu 15.04. While doing

npm install fsevents


I'm gettting following error:

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.11
npm WARN tutorial@1.0.0 No repository field.


Has anybody solved this? TIA!

Answer

I was facing the same issue with this dependecy when building other application.

Just for the sake of knowledge and to people who are not well used to NPM, and thus uncertain about how their applications will behave:

Since fsevents is an API in OS X allows applications to register for notifications of changes to a given directory tree. Running:

npm install --no-optional

Will do the trick, with no drawbacks.