matth3o matth3o - 2 months ago 36
Dart Question

Dart versioning - no matching version

In my angular2 project I don't manage to add the "google_maps: 3.1.0" dependency.
It seems that this library is in conflict with "angular2: 2.0.0-beta.20".

The error message is :

Package code_transformers has no versions that match >=0.4.1 <0.5.0 derived from:
- build 0.3.0 depends on version ^0.4.1


However, "google_maps: 3.1.0" do not contain "code_transformers" or "build" package in its dependencies and transitive dependencies.

Thanks for your help.

Answer

This means that pub get or pub upgrade could not find a set of dependencies that are compatible.

Try to commenting out all dependencies except two and run pub get or pub upgrade again. Then add one dependency and run again and so on until you get the error. This way you can figure out what dependency causes the problem.

Don't use any as dependency constraint in your pubspec.yaml. This is known to cause troubles because pub has to analyze the whole search space which is gigantic.