kehinde kehinde - 2 months ago 25
Java Question

Enterprise application build-impl.xml throws error

I am using Glassfish-4.0, Netbeans-8. I started trying out a sample enterprise application. I have tried this same tutorial a couple of times trying to get where and when exactly the problem got infused in the application. To my surprise, it is from the onset. Once I create a new application by doing this in Netbeans:
Project => J2EE => Enterprise Application => Entered the project name => selects glassfish and JDK-7 and clicked finished. I tried running this application as is and it throws this error in the build-impl.xml file. on this line:
This is in the ContactProject-ejb project.

934 <nbdeploy debugmode="false" forceRedeploy="${forceRedeploy}"/>

While a similar error throws up in the ContactProject file

<target name="-run-deploy-am" unless="no.deps">
<!-- Task to deploy to the Access Manager runtime. -->
<ant antfile="${project.ContactApp-ejb}/build.xml" inheritall="false" target="-run-deploy-am"/>
<ant antfile="${project.ContactApp-war}/build.xml" inheritall="false" target="-run-deploy-am"/>
<target depends="-init-cos,dist-directory-deploy,pre-run-deploy,-pre-nbmodule-run-deploy,-run-deploy-nb,-init-deploy-ant,-deploy-ant,-run-deploy-am,-post-nbmodule-run-deploy,post-run-deploy" name="run-deploy"/>
<target if="netbeans.home" name="-run-deploy-nb">
<nbdeploy clientModuleUri="${client.module.uri}" clientUrlPart="${client.urlPart}" debugmode="false" forceRedeploy="${forceRedeploy}"/>
<target name="-init-deploy-ant" unless="netbeans.home">
<property name="deploy.ant.archive" value="${dist.jar}"/>
<property name="deploy.ant.resource.dir" value="${resource.dir}"/>
<property name="deploy.ant.enabled" value="true"/>
<target depends="dist,-run-undeploy-nb,-init-deploy-ant,-undeploy-ant" name="run-undeploy"/>
<target if="netbeans.home" name="-run-undeploy-nb">
<fail message="Undeploy is not supported from within the IDE"/>
<target depends="dist" name="verify">
<nbverify file="${dist.jar}"/>

what exactly could be the problem with this? Thanks.
Sorry, this is the error when I try running the ejb file. I have searched the log of Glassfish, it's blank, so no indication if whatsoever is going on.

In-place deployment at C:\Users\Ken4ward\Documents\NetBeansProjects\ContactApp\ContactApp-ejb\build\classes
GlassFish Server 4, deploy, null, false
C:\Users\Ken4ward\Documents\NetBeansProjects\ContactApp\ContactApp-ejb\nbproject\build-impl.xml:935: The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 1 minute 10 seconds)


You are not even providing the error message...

It looks like the problem is that you didn't build the submodules (i.e. the EJB and the WAR project) and therefore Maven can't find the artifacts in your local repository.

To fix this either build the parent Maven project (the parent of the EAR projecT) or right-click on your EAR project and click "Build with Dependencies".

If this doesn't fix the problem, update the question with the real error message (Hint: The message containing the line number in the build-impl.xml is not the real error message).