user2692997 user2692997 - 7 months ago 52
Java Question

Error:Unable to run mksdcard SDK tool in ubuntu

having an error trying to install android studio on Ubuntu keep getting this error in the set-up wizard

"Unable to run mksdcard SDK tool."


also in the terminal i get this:

[ 115528] ERROR - tRunWizard$SetupProgressStep$1 - Android Studio 1.1.0 Build #AI-135.1740770
[ 115531] ERROR - tRunWizard$SetupProgressStep$1 - JDK: 1.8.0_40
[ 115531] ERROR - tRunWizard$SetupProgressStep$1 - VM: Java HotSpot(TM) 64-Bit Server VM
[ 115531] ERROR - tRunWizard$SetupProgressStep$1 - Vendor: Oracle Corporation
[ 115531] ERROR - tRunWizard$SetupProgressStep$1 - OS: Linux
[ 115532] ERROR - tRunWizard$SetupProgressStep$1 - Last Action:


please help and thanks in advance

Answer

This really needs to be added to the documentation, which is why I filed an issue about it a few months ago...

You need some 32-bit binaries, and you have a 64-bit OS version (apparently). Try:

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

That worked for me on Ubuntu 14.10.

Comments