Sunil Sharma Sunil Sharma - 5 months ago 29
Android Question

How to Solve 'Manifest merger failed' error in android-studio?

Error from androidmanifest.xml :


Execution failed for task ':app:processDebugManifest' Manifest
merger failed : uses-sdk:minSdkVersion 1 cannot be smaller than
version 7 declared in library
[com.android.support:appcompat-v7:23.2.0]
C:\Users\bsuni\AndroidStudioProjects\Rec\app\build\intermediates\exploded-aar\com.android.support\appcompat-v7\23.2.0\AndroidManifest.xml
Suggestion: use tools:overrideLibrary="android.support.v7.appcompat"
to force usage

Answer

I have regenerate this error :

You have selected minSdkVersion to 1 while you created project.

as well as you are using :

compile 'com.android.support:appcompat-v7:23.2.0'
compile 'com.android.support:design:23.2.0'

due to this error occurs.

suggestion by android-studio :

use android.support.v7.appcompat

solution : change in gradle

minSdkVersion 7