Albin Shaju Albin Shaju - 1 month ago 83
Android Question

Android Studio 2.2 blank AVD & VCPU Shutdown request

I am using Android Studio 2.2 and when I try to do a trial run of hello world program, I am getting AVD with blank screen. Also In-between that the

VCPU shutdown request
coming in the log.I am not getting any android welcome screen after a long time (More Than 30 minutes). There is no issue with RAM performance, I already have 16gb. All the components are installed correctly from
SDK
. Can you help me to solve this issue? Please Find the Image below for Blank AVD AS2.2

enter image description here

Error Log:

C:\Users\hp\AppData\Local\Android\Sdk\tools\emulator.exe -netdelay none -netspeed full -avd Nexus_5_API_24
Hax is enabled
Hax ram_size 0x40000000
HAX is working and emulator runs in fast virt mode.
emulator: Listening for console connections on port: 5554
emulator: Serial number of this emulator (for ADB): emulator-5554
emulator: emulator window was out of view and was recentered
VCPU shutdown request
EAX=00748cea EBX=3ffadb60 ECX=00000000 EDX=00000000
VCPU shutdown request

Answer

Dealing with the same issue. Something to do with haxm on 7th gen processors as the arm image works.

UPDATE: Confirmed to be a HAXM issue on Kaby Lake, nothing we can do until we get an HAXM update from Intel. Either use the ARM image or ad the switch -accel off -verbose to the x86/x64 image....neither are desirable but will do the trick until we get a fix. You can also use an android device but that can be frustrating too.