Marc van der Peet Marc van der Peet - 2 months ago 15x
R Question

Error trying to install package for iris dataset

I just installed R on my new computer and want to install some packages. But im running into some strange errors when doing this.

When I do this:


I get the following error:

Installing package into ‘C:/Users/Marc/Documents/R/win-library/3.2’
(as ‘lib’ is unspecified)
Warning message:
ackage ‘iris’ is not available (for R version 3.2.2)

I especially dont get the unspecified lib part as I just set it (.libPaths("C:/Users/Marc/Desktop/R/Library"))

Any thoughts on what is causing this error?


Because there is no iris package (as @etienne said). If you do ?iris (or google for it) it tells you that iris dataset comes with datasets package.

I thought datasets package came bundled with R. (If it doesn't, install.packages('datasets', ...)