zozelfelfo zozelfelfo - 28 days ago 10
Android Question

Error INSTALL_FAILED_NO_MATCHING_ABIS after updating Nexus 5x to Oreo

I was working on an old app I have (I started it on 4.0), and I am facing some issues after upgrading my nexus 5x to Oreo (8.0).

My Nexus 5x is a x86 device, and everytime I try to install this apk for debug porpuses I get the so called error "INSTALL_FAILED_NO_MATCHING_ABIS". I had never faced this problem before so I started to look for information and the only thing I found that could be useful was:

splits {
abi {
enable true
reset()
include 'x86', 'armeabi-v7a'
universalApk true
}
}


In my build.gradle file.

However this did not work, in order to make sure that the problem was the 8.0 and not another external factor, I created a virtual nexus 5x with Nougat (7.1) and it runs ok, but when I upgrade the virtual device to 8.0 I face the same ABI error.

My app does not use grade in its full potential (is really old), but I have this version of the plugin:

dependencies {
classpath 'com.android.tools.build:gradle:2.2.0'
}


}

My current version of Android Studio is 2.3.3, I have not updated yet to 3.0 as it is in beta phase.

I also have installed the Intel x86 Emulator Accelerator (HAXM installer) v 6.2.1

Any indications will be apreciated

Thanks in advance

Answer Source

Well the problem was finally solved,

The problem was that I had other projects, and my main project linked to these additional projects. One of them was google-play-services-lib and when I generated the apk a google-play-services.jar.properties file was copied to the libs folder.

Removing that google-play-services.jar.properties file from the project solved the problem completely.

Here you have the full stack in Google:

https://issuetracker.google.com/issues/65941637

Thanks everyone for your comments!