R Question

Install package "rio" because of feather

I try in R to install the CRAN-packages "rio" but receive the following error:

install.packages("rio", dependencies = TRUE)

Installing package into ‘C:/software/Rpackages’
(as ‘lib’ is unspecified)
also installing the dependency ‘feather’

There is a binary version available but the source
version is later:
binary source needs_compilation
rio 0.4.0 0.4.8 FALSE

Package which is only available in source form, and may
need compilation of C/C++/Fortran: ‘feather’
These will not be installed
installing the source package ‘rio’

trying URL 'https://cran.rstudio.com/src/contrib/rio_0.4.8.tar.gz'
Content type 'application/x-gzip' length 40366 bytes (39 KB)
downloaded 39 KB

ERROR: dependency 'feather' is not available for package 'rio'
* removing 'C:/software/Rpackages/rio'
Warning in install.packages :
running command '"C:/PROGRA~1/R/R-32~1.4RE/bin/x64/R" CMD INSTALL -l "C:\software\Rpackages" C:\Users\BJRNAU~1\AppData\Local\Temp\Rtmp6rf71B/downloaded_packages/rio_0.4.8.tar.gz' had status 1
Warning in install.packages :
installation of package ‘rio’ had non-zero exit status

The downloaded source packages are in
‘C:\Users\BjørnAugust\AppData\Local\Temp\Rtmp6rf71B\downloaded_packages’


Can anyone help me install the packages?

Answer

This was an unintended consequence of importing feather in the latest release of rio. It will be correctly soon in the next release of rio to CRAN. In the meantime, you have a couple of options.

1) Install the development version from GitHub using something like:

devtools::install_github("leeper/rio")
# or
ghit::install_github("leeper/rio")

This version (v0.4.11) makes feather optional, so it is installable on older Windows versions.

2) Install an older version of rio:

packageurl <- "https://cran.r-project.org/src/contrib/Archive/rio/rio_0.4.6.tar.gz"
install.packages(packageurl, repos=NULL, type="source")

But note that this will potentially require manual install of package dependencies.

3) Upgrade to the latest version of R (v3.3.1) so that you can install feather (and thus rio).