Ed de Almeida Ed de Almeida - 3 months ago 47
Sass (Sass) Question

Error installing grunt-sass

I'm trying to install grunt-sass using npm, according to what is said here, running the following command

npm install --save-dev grunt-sass


It happens that I'm receiving an error message:

UNMET PEER DEPENDENCY grunt@>=0.4.0


and then again

npm WARN grunt-contrib-sass@1.0.0 requires a peer of grunt@>=0.4.0 but none was installed.
npm WARN grunt-sass@1.2.0 requires a peer of grunt@>=0.4.0 but none was installed.


But when I run

grunt --version


I get the following result

grunt-cli v1.2.0
grunt v0.4.5


This says I have grunt 0.4.5 and it requires only 0.4.0, so it should be working fine.

Any suggestions about what is causing this?

Answer

It all got resolved when I intalled the gem sass. All I had to do was

gem install sass

and then

grunt build

It seems there is a dependency here, but it says nothing in the error message to help one find this out. A documentation problem, more than a bug.