Hiragitou Saiga Hiragitou Saiga - 1 month ago 130
Android Question

Update Gradle version on Android Studio 2.0

I have updated my Android Studio last night to version 2.0
Then i cannot run app anymore. My Android Studio said that

"This version of Android Studio is incompatible with the Gradle Plugin used. Try disabling Instant Run (or updating either the IDE or the Gradle plugin to the latest version"

I already have updated my Gradle to the lastes version but it's don't solve the problem.

Here is my build.gradle.


classpath 'com.android.tools.build:gradle:2.1.0-alpha1'.

classpath 'com.neenbedankt.gradle.plugins:android-apt:1.4'

classpath 'me.tatarka:gradle-retrolambda:3.2.0'

classpath 'com.google.gms:google-services:2.0.0-alpha6'


And warrper


distributionUrl=https://services.gradle.org/distributions/gradle-2.10-all.zip

Answer

It's always recommended to use stable version of Android Gradle Plugin. So, update your project build.gradle from classpath 'com.android.tools.build:gradle:2.1.0-alpha1' to stable version follows.Then try clean and build let me know aftermath.

classpath 'com.android.tools.build:gradle:2.0.0'

And see Doug Stevenson's advice.

Comments