StackFlowed StackFlowed - 2 months ago 11
Git Question

Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo cannot run git

The IDE is giving an error message that it

can't start git: /usr/bin/git
, however the path is correct, and it was working before. idea.log contains the following error:

Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo

Answer

This generally occurs after the mac OS update. All you need to do in terminal is run sudo xcodebuild -license and then agree to the terms.