Nyein Nyein - 27 days ago 28
Ruby Question

Can not find jsonapi parser 0.1.1

When I run rails server, 'Could not find jsonapi-parser-0.1.1.beta2' error shows up.

~/ruby_on_rails/test/sampleapp$ rails s
Could not find jsonapi-parser-0.1.1.beta2 in any of the sources
Run `bundle install` to install missing gems.
~/ruby_on_rails/test/sampleapp$ bundle install
Fetching gem metadata from https://rubygems.org/.........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Could not find jsonapi-0.1.1.beta4 in any of the sources

Answer

jsonapi beta4 is not available. only beta5, beta 1,beta2 are available. you could find this here

Add this line in your gemfile if not and then run bundle install.

gem 'jsonapi-parser', '~> 0.1.1.beta2' gem 'jsonapi', '~> 0.1.1.beta5'

This might be due to the method which requires jsonparser which is not included in your rails app.

Comments