Lata Sawant Lata Sawant - 2 months ago 33
Android Question

Phone Authentication in Firebase gives error in android

Error:(24, 32) error: cannot find symbol class PhoneAuthCredential


Gradle

compile 'com.google.firebase:firebase-database:10.2.0'

compile 'com.google.firebase:firebase-storage:10.2.0'
compile 'com.google.firebase:firebase-messaging:10.2.0'
compile 'com.google.firebase:firebase-config:10.2.0'
compile 'com.firebaseui:firebase-ui-auth:1.2.0'
compile 'com.github.bumptech.glide:glide:3.6.1'
compile 'com.android.support:multidex:1.0.1'
compile 'com.android.support:design:25.3.1'
compile 'com.facebook.android:facebook-android-sdk:4.16.0'
compile 'com.google.android.gms:play-services-auth:10.2.0'
compile 'com.google.firebase:firebase-auth:10.2.0'


What other gradle file to include to resolve the error for phone authentication in Firebase?Please help

Answer Source

Firebase phone authentication is being supported since the 11.0.0 version of firebase sdk

so you should use the new version of it and the 11.2.0 the last version of it

compile "com.google.firebase:firebase-auth:11.2.0"