jhnath jhnath - 2 months ago 18
Git Question

Invalid active developer path error after upgrading to El Capitan

I ran into this error trying to push to git, when I typed git init.


xcrun: error: invalid active developer path

(/Library/Developer/CommandLineTools), missing xcrun at:
/Library/Developer/CommandLineTools/usr/bin/xcrun


I tried the following solutions.

xcode-select —install,
sudo xcode-select -switch,
sudo xcode-select —install,
brew doctor,
brew update,
brew upgrade,
brew cleanup

Answer

1)

try typing in "xcode-select -print-path" and see if the path you see is the path you're expecting for your current Xcode version.

2)

If you go to:

https://developer.apple.com/downloads/

(you'll need to sign in with your Apple Developer account)

Once there, you'll see links for "Command Line Tools". It sounds like you need to install MacOS 10.11 Command Line Tools for Xcode 7.