Felix Grossmann Felix Grossmann - 1 year ago 116
R Question

ggiraph plot is shifted in shiny app

This is my example:

library(shiny)
library(ggplot2)
library(ggiraph)

df <- data.frame(achseX = c("A", "b"), achseY = c(12, 22))

server <- function(input, output) {
output$plot <- renderggiraph({
gg <- ggplot(data = df) + geom_bar_interactive(aes(tooltip = achseY, x = achseX, y = achseY), stat = "identity") +
theme_minimal()
return(ggiraph(code = print(gg), selection_type = "multiple", zoom_max = 4,
hover_css = "fill:#FF3333;stroke:black;cursor:pointer;",
selected_css = "fill:#FF3333;stroke:black;"))
})
}

ui <- fluidPage(
"The plot should start right under this text.",
ggiraphOutput("plot") ,
"This is where the plot should end."
)

shinyApp(ui = ui, server = server)


When I start the app, the result looks like:

enter image description here

I added the text lines to show where the plot should be positioned. As you can see, the plot is shifted to another position. The same thing happens when I start the shiny examples:

# example 1:
shiny::runApp(appDir = system.file("shiny/crimes", package = "ggiraph"), display.mode = "showcase")
# example 2:
shiny::runApp(appDir = system.file("shiny/cars", package = "ggiraph"), display.mode = "showcase")



Did I missed something? How can I get this plot to the right position?


EDIT:

Session info:

R version 3.4.0 (2017-04-21)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows Server 2008 R2 x64 (build 7601) Service Pack 1

Matrix products: default

locale:
[1] LC_COLLATE=German_Germany.1252 LC_CTYPE=German_Germany.1252 LC_MONETARY=German_Germany.1252
[4] LC_NUMERIC=C LC_TIME=German_Germany.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] gdtools_0.1.4 ggiraph_0.4.0 ggplot2_2.2.1 shiny_1.0.3

loaded via a namespace (and not attached):
[1] zip_1.0.0 Rcpp_0.12.11 compiler_3.4.0 plyr_1.8.4 R.methodsS3_1.7.1 R.utils_2.5.0
[7] base64enc_0.1-3 tools_3.4.0 digest_0.6.12 uuid_0.1-2 jsonlite_1.5 tibble_1.3.3
[13] gtable_0.2.0 rlang_0.1.1 DBI_0.7 yaml_2.1.14 officer_0.1.4 dplyr_0.5.0
[19] xml2_1.1.1 htmlwidgets_0.8 grid_3.4.0 R6_2.2.2 rvg_0.1.4 purrr_0.2.2.2
[25] magrittr_1.5 scales_0.4.1 htmltools_0.3.6 assertthat_0.2.0 mime_0.5 xtable_1.8-2
[31] colorspace_1.3-2 httpuv_1.3.5 labeling_0.3 lazyeval_0.2.0 munsell_0.4.3 R.oo_1.21.0

Answer Source

This is a visualisation bug in RStudio and Internet Explorer. It works fine in Google Chrome. Could not test it for Mozilla Firefox though.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download