El Marce El Marce - 29 days ago 14
Java Question

How to change from -source 1.6 to -source 7 in IntelliJ IDEA

I' trying to build a in IntelliJ IDEA project that is not mine and I got the following error:

java: diamond operator is not supported in -source 1.6
(use -source 7 or higher to enable diamond operator)


How do I change this setting in IntelliJ IDEA?

Answer

Ctrl+Alt+Shift+S (Project Structure icon)

Then change Project language level

Comments