Ahmed Abed Ahmed Abed - 1 month ago 14
Android Question

Android - Use Fingerprint API in Android API 17

Recently, Google allowed developers to use Fingerprint API in Android 6.0 (API 23).

I have an android project with

compiledSdkVersion 23
and
minSdkVersion 17
.

My question is: Can i use Fingerprint API in my project, i tried to use Google sample in my project but i have this error message:

Class Requires API level 23 (current min is 17)


if i can i will be grateful to any one gives me a good tutorial.

thank you

Answer

you can use Support Library v4 to support minSdk less than 23. You have to use class name accordingly e.g. FingerprintManagerCompat, etc.

Check this github sample