daveomcd daveomcd - 7 months ago 16
Ruby Question

Capistrano deployment broken by new request for Capistrano-Harrow gem?

I thought my capistrano version was locked to 3.4.0, however it seems that it updated to 3.5. I tried going back to 3.4, but I keep getting the following message when I try to deploy my project to server.

DEBUG [72bb6fc3] An error occurred while installing capistrano-harrow (0.3.2), and Bundler cannot
continue.
Make sure that `gem install capistrano-harrow -v '0.3.2'` succeeds before
bundling.


I'm not familiar with
capistrano-harrow
, but read a little and doesn't seem like something I need. I did add to my gemfile in hopes of getting the deployment to send but even though that seemed to install fine, it still errors out for deployment. When I try executing
gem install capistrano-harrow -v '0.3.2'
- I get the following message and it doesn't install.

ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
bad response Not Found 404 (https://rubygems.global.ssl.fastly.net/quick/Marshal.4.8/capistrano-harrow-0.3.2.gemspec.rz)


Anyone know how I can either, opt out of harrow to try and get my deploy to work, or correct this issue to move forward? Thanks!

Update

I ran the following command to "opt-out", however, it still needs to build/install the gem I suppose which is currently the real issue.

git config harrow.disabled true

Answer

capistrano-harrow's 0.3.2 version seems to be yanked from Rubygems. There's a hint in the ERROR message you've pasted: Not Found 404 was received from the CDN.

If you're back on 3.4, the gem is not supposed to be in use but if you're running 3.5, please try to bundle update capistrano.

Comments