Christopher Francisco Christopher Francisco - 1 year ago 113
Node.js Question

NPM erros when installing zombie 4.2.1 on Centos 6.7

I'm running a vagrant

box. My node version is
and my npm version is
. When I run
npm install zombie@4.2
I get the following error:

node-gyp rebuild

make: Entering directory `/home/vagrant/zombie-test/node_modules/bufferutil/build'
CXX(target) Release/
In file included from ../src/
../../nan/nan.h:43:3: error: #error This version of node/NAN/v8 requires a C++11 compiler
In file included from ../src/

/* stack trace */

make: Leaving directory `/home/vagrant/zombie-test/node_modules/bufferutil/build'
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12)
gyp ERR! System Linux 2.6.32-573.el6.x86_64
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/vagrant/zombie-test/node_modules/bufferutil
gyp ERR! node -v v6.9.1
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

Full stack trace here

Both node and npm were installed using this instructions:

$ curl --silent --location | bash -
$ yum -y install nodejs

Any known solutions for this error?

Answer Source

You'll need a newer gcc/g++ version (the one that ships with CentOS6 is way too old). Take a look at this: - where you can update the building tools to decent/recent versions.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download