eitan barazani eitan barazani - 23 days ago 6
C# Question

How to solve DEP6500 and DEP6701 errors?

I have a project called BTLE in its own solution. Loading the project and running it with the debugger on the phone works find.

I have a second solution that Loads and compile fine as well.

I added the BTLE project (Add/Existing Project) to the second solution, compiled it and tried to run it in the debugger.

I can see the application was loaded fine to the phone (I can run it from the phone), but the debugger will not start and I am getting the following error messages:

1>------ Deploy started: Project: BTLE, Configuration: Debug ARM ------
1>Deploying to Phone Internal Storage...
1>Updating the layout...
1>Copying files: Total 2 mb to layout...
1>Checking whether required frameworks are installed...
1>Registering the application to run from layout...
1>Deployment complete (0:00:05.469). Full package name: "76081875-4de1-4857- 8ce6-4e7a580ee1b6_1.0.0.0_arm__fdr7mxj3cnxqw"
2>------ Deploy started: Project: STPWindows, Configuration: Debug ARM ------
2>DEP6500 : A specified communication resource (port) is already in use by another application. 0x89731800:
2>DEP6701 : Bootstrapping failed with unexpected error: 'DEP6500 : A specified communication resource (port) is already in use by another application. 0x89731800: '.
========== Deploy: 1 succeeded, 1 failed, 0 skipped ==========


Any idea why I am getting these error messages?

Thx

Answer

You did not mention if your multiple project solutions have multiple startups.

See screenshot below.

enter image description here

Under Action, Change the relative actions of each projects and try deploying.