Ronit Ronit - 21 days ago 14
Swift Question

OAuth integration error

I have integrated

OAuth Framework
in the application with the help of cocoa pod as per the information given in this GitHub installation page?

I am using Xcode 7.3 and swift 2.2 . When I try to build the app i am getting the following errors:

enter image description here

I do not understand why am I getting so many errors.

Answer

You are using the wrong version. The syntax for Swift 3 is very different from Swift 2.2

From the installation page:

OAuth2 requires Xcode 8, the built framework can be used on OS X 10.9 or iOS 8 and later. Happy to accept pull requests, please see CONTRIBUTING.md

You can find the correct release in the project's releases page