Mihai Mihai - 4 months ago 157
iOS Question

No such module 'OneSignal'

I'm trying to integrate OneSignal SDK in Xcode 7.2.1 with CocoaPods 1.0.0.beta.2 and use_frameworks! directive.
When I try to import the framework in AppDelegate.swift I get No such module 'OneSignal'.
I also have other frameworks included from Cocoapods which work with no problem (ex: Fabric)

I managed to install OneSignal SDK with cocoapods in another project, but without the use_frameworks! directive. I used the bridging header.

Answer

Pods written in Swift can be imported with the use_frameworks!, and CocoaPods will complain if you don't do this and try to import the pods in Swift code.

Although any pods not written in Swift, will require the use of a bridging header.

Referencing to the OneSignal pod, the getting-started guide instructs applications using Swift to include a bridging header in order to use the pod. OneSignal: Getting Started Guide

Comments