Loknar Loknar - 17 days ago 8
Python Question

Unsupported command-line flag: --ignore-certificate-errors

Using Python 2.7.5, python module selenium (2.41.0) and chromedriver (2.9).

When Chrome starts it displays a message in a yellow popup bar: "You are using an unsupported command-line flag: --ignore-certificate-errors. Stability and security will suffer." This simple example reproduces the problem.

from selenium import webdriver
browser = webdriver.Chrome()
browser.get("http://google.com/")


How do I remove this command-line flag in python selenium?

Answer

This issue is resolved as of Chromedriver 2.11 (released Oct 2014). Updating will now do the trick.

Comments