Carlton Carlton - 1 year ago 125
Android Question

Gradle Sync Fail

I get this error when trying to build my app:

Could not find
Required by:

Gradle version:

classpath ''

Android studio version;

android {
compileSdkVersion 23
buildToolsVersion '25.0.0'
defaultConfig {
applicationId "MyApp"
minSdkVersion 22
targetSdkVersion 23
versionCode 1
versionName "1.0"

I tried going to SDK TOOLS and enabling the constraint solver, but I did not help. This happened just today, and have not have had this issue earlier. Any ideas?

Answer Source

Check if you have installed ConstraintLayout. Open SDK Manager and than in SDK Tools tab you can check what version of ConstarintLayout is installed.

SDK Tools

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download