Dario Dario - 29 days ago 14
Java Question

Opening JNLP File in Java 6 JRE instead of JRE 7

I have Java 6-based Java Web Start application that I need to open on a Windows machine. The machine has JRE 7 installed, with JRE 6 copied manually to the

Program Files
folder. The problem is that whenever I want to open the JWS application, it opens using Java 7. Even if I use the
javaws
executable from JRE 6, some properties still refer to JRE 7 files (I verified this by using
javaws -verbose app.jnlp
. How can I force JRE 6 just for this application?

Answer

I have Java 6-based Java Web Start application ..How can I force JRE 6 just for this application?

Use an appropriate version attribute in the j2se element.

<resources>
    <!-- Any 1.6 JRE -->
    <j2se version='1.6*'>
    ...
</resources> 

Warning

This solution no longer seems to work for installing earlier versions of the JVM!

The best reason I can think of for why it would fail to work is that Oracle is tiring of releasing security updates for earlier Java versions - so is forcing every user to use the latest JVM.