Jon Hodgson Jon Hodgson - 1 month ago 5
Ruby Question

Trouble changing ruby version for sh

I'm having a little trouble configuring ruby in OSX.

Under bash, all is well, version 2.3.1 is running, my gems are installed in 2.3.1, all hunky dory

But in sh, version 2.3.0 is running. I can't see where that is set, having looked in the profiles.

This is an issue because I'm using an application that opens up a bourne shell to do some work.. and the work involves ruby.

I tried 'rvm use' but I get an "rvm is not a function" message.

typing ~/.rvm/scripts/rvm doesn't help

Answer

Try installing via homebrew, after it installs it should show you how to symlink it to the system install.