xPTM1219 xPTM1219 - 1 month ago 24
Linux Question

How to use gtkmm in Netbeans or Eclipse

Hi Stackoverflow community, I hope everything is fine.
You may be saying"there is a lot of posts on this already", but here is the thing. I still haven't resolve my problem of not being able to compile a class with gtkmm, yes after reading everything. I currently have, Ubuntu 16.04.
As the title says, I want to know how to get gtkmm working with eclipse or netbeans please I beg you, do it with all the details possible. I could get it working in Ubuntu terminal(who by default brings the gtkmm and c++ compiler pre-installed), the case is that I want an IDE to have gtkmm because if in any moment I develop a program that has more than 5 classes I would have to compile all the files in the terminal. Which in exchange having an IDE with these tools is a better option for a bigger program.

Things that I have done: I've installed pkg-config and selected gtkmm-3.0 option in eclipse it just give thousands of errors in the console plus saying that some files are missing and when I tell eclipse where is it, it just says there is another file missing and the chain continues.
In netbeans it just give me (BUILD FAILED (exit value 2, total time: 7s)) error and much more like this make: *** [.build-impl] Error 2. And like 10 solutions additional these, if you have any questions please tell me.

Sorry for the large post, thanks for reading and have a nice day.

Answer

you can see this post about how to configure netbeans IDE for gtkmm on linux the example in the post use ubuntu 16.04