user309838 user309838 - 2 months ago 13
Ruby Question

Ruby on rails - Error during bundle install

I've been googling this error below, but I can't solve this error:

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

/usr/bin/ruby2.1 extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

extconf failed, exit code 1

Gem files will remain installed in /home/dyego/.bundler/tmp/9200/gems/sqlite3-1.3.9 for inspection.
Results logged to /home/dyego/.bundler/tmp/9200/extensions/x86_64-linux/2.1.0/sqlite3-1.3.9/gem_make.out
An error occurred while installing sqlite3 (1.3.9), and Bundler cannot continue.
Make sure that `gem install sqlite3 -v '1.3.9'` succeeds before bundling.
run bundle exec spring binstub --all
/usr/lib/ruby/vendor_ruby/bundler/resolver.rb:296:in `resolve': Could not find gem 'sqlite3 (>= 0) ruby' in the gems available on this machine. (Bundler::GemNotFound)
from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:168:in `start'
from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:129:in `block in resolve'
from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:128:in `catch'
from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:128:in `resolve'
from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:179:in `resolve'
from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:114:in `specs'
from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:159:in `specs_for'
from /usr/lib/ruby/vendor_ruby/bundler/definition.rb:148:in `requested_specs'
from /usr/lib/ruby/vendor_ruby/bundler/environment.rb:18:in `requested_specs'
from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:13:in `setup'
from /usr/lib/ruby/vendor_ruby/bundler.rb:120:in `setup'
from /usr/lib/ruby/vendor_ruby/bundler/setup.rb:17:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'


So I googled this error:


mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h


and I got some similar questions like this one:
Error while installing json gem 'mkmf.rb can't find header files for ruby'

But I already installed ruby-dev:

sudo apt-get install ruby-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
ruby-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 72 not upgraded.


I'm really struggling to solve this problem (even though it seems to be a simple one).

Answer

Try to install the ruby-dev library for your Ruby version which is 2.1

$ sudo apt-get install ruby2.1-dev