Learner Learner - 21 days ago 7
Android Question

Android : Emulator doesn't launch

I am trying to create a simple app. I created a new AVD. I launched it. I have been waiting for an hour, but the emulator shows only ANDROID. I am stuck. Can someone please help.

The image of how it is for an hourstuck Please don't mark duplicate. I searched and tried as much I can.

Is there anything I am doing wrong ? Help, please !!

My emulator creationemulator creation

I again launched the AVD and got this log. I think someone can definitely find the mistake that I am doing from this.

Creating filesystem with parameters:

ERROR: couldn't get path to resize2fs binary


Size: 576716800
Block size: 4096
Blocks per group: 32768
Inodes per group: 7040
Inode size: 256
Journal blocks: 2200
Label:
Blocks: 140800
Block groups: 5
Reserved block group size: 39


Created filesystem with 11/35200 inodes and 4536/140800 blocks
Creating filesystem with parameters:


Size: 69206016
Block size: 4096
Blocks per group: 32768
Inodes per group: 4224
Inode size: 256
Journal blocks: 1024
Label:
Blocks: 16896
Block groups: 1
Reserved block group size: 7
Created filesystem with 11/4224 inodes and 1302/16896 blocks
emulator: device fd:780

HAXM is not working and emulator runs in emulation mode

emulator: The memory needed by this AVD exceeds the max specified in your HAXM configuration.


emulator: AVD RAM size = 1536 MB
emulator: HAXM max RAM size = 1024 MB
emulator: You might want to adjust your AVD RAM size and/or HAXM configuration to run in fast virt mode.


creating window 23 46 193 322
emulator: UpdateCheck: current version '24.4.0', last version '24.4.0'

Answer

Ram allocated to avd is exceeding ram allocated to HAXM. Either increase RAM of HAXM( not a good idea if you have 4 GB ram on your PC) or decrease ram of your AVD to match 1024 mb or lower.

I suggest creating emulator for some old device config like nexus s and using X86 images .

Post further queries if this dose not work.

Comments